Medtronic 670G Flakey Communications During Data Upload


(Jess) #1

I’ve been having problems with Carelink uploading. It only appears to work about 1 out of 5 times. The pump has to be very close to the Carelink Next glucose meter, and I have never been able to get this to work with the included USB extension cable.

I called Medtronics, and they suggested radio interference might be causing the problem, and suggest putting an aluminum turkey pan over the pump and meter to act as a shield; Real Professional.

I feel, if Medtronics designs such a flakey system, the least they could do is to included a shielded enclosure to place the pump and meter into while uploading. I’ve always gotten it to work, but it does require about 5 minutes of repositioning the pump and retrying every time.

Any other 670G users out there with this issue? I don’t think my unit is defective, I think the design is crap.


(Dennis J. Dacey, PwD) #2

Oh, that’s too bad Jess @MrEntropy I’ve never had upload problems with the Carelink dongle, the CONTOUR Next Link meter of the DB Meter; what I do miss was the two-way communications with the BD Meter. I do use an extension cable with the desktop PC but don’t bother with that with the laptop and there the CONTOUR Next is pointed away from my pump - I avoid problems by not upgrading to the 670.

One of the first things you should look at is the serial port on your computer - those things get messed up from constantly having things getting plugged in.


(tored) #3

Sorry to hear you’ve had problems w/ the 670G sys. I have the same thing and have not had any issues w/ uploading my pump data to CARELink. I initially had a problem w/ trying to find the right browser and Java version that it works with. I called Medtronic and they got it to work. The IE browser that supports the Java is IE vers. - 11371.16299.0 and I’m not sure of the Java version. Medtronic should be able to help you out. Every time I upload my pump to that website, it asks for a Java update and I always say, just this one time, because it won’t work on any other version. I have the browser icon on my desktop so all I have to do is click on it and I’m right there on the CARELink logon page.I also always rest the pump on the meter before I do the download. That way I know there shouldn’t be an issue with the connection. If you still have problems, call Medtronic and tell them and see what they say.